Why Doesn’t This Surprise Me?

Here’s one for you all … the FEMA website not only requires a section 508 non-compliant anti-spam filter, it is Windows + IE 6 only. So, if you are a Mac or Linux user or you are blind and you managed to survive Katrina, good luck filing a claim. Looks like these people should be taking some usability courses. Take a peek … Unreal.

Leave a Reply